aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLibravatarUnit 193 <unit193@ubuntu.com>2019-11-20 17:27:41 -0500
committerLibravatarUnit 193 <unit193@ubuntu.com>2019-11-20 17:27:41 -0500
commitbcf819cb6cc9a81d67f254850fae00f74c308958 (patch)
treefb2efaeefd3159a83ca086af3051eaf3dfb05786
parentafc97247cc0979e24d79eb5f790d72cce601bafc (diff)
downloadruby-roo-bcf819cb6cc9a81d67f254850fae00f74c308958.tar.bz2
ruby-roo-bcf819cb6cc9a81d67f254850fae00f74c308958.tar.xz
ruby-roo-bcf819cb6cc9a81d67f254850fae00f74c308958.tar.zst
d/control, d/p/allow-newer-rubyzip.patch: Drop upper constraint on rubyzip.
-rw-r--r--debian/control2
-rw-r--r--debian/patches/allow-newer-rubyzip.patch14
-rw-r--r--debian/patches/series1
3 files changed, 15 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index a01fd7e..d577244 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,6 @@ Build-Depends: debhelper-compat (= 12),
ruby-nokogiri (>= 1),
ruby-rspec,
ruby-simplecov,
- ruby-zip (<< 2.0.0),
ruby-zip (>= 1.1)
Rules-Requires-Root: no
Standards-Version: 4.3.0
@@ -21,7 +20,6 @@ Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
Depends: ruby | ruby-interpreter,
ruby-nokogiri (>= 1),
- ruby-zip (<< 2.0.0),
ruby-zip (>= 1.1),
${misc:Depends}
Description: can access the contents of various spreadsheet files
diff --git a/debian/patches/allow-newer-rubyzip.patch b/debian/patches/allow-newer-rubyzip.patch
new file mode 100644
index 0000000..72313dc
--- /dev/null
+++ b/debian/patches/allow-newer-rubyzip.patch
@@ -0,0 +1,14 @@
+Description: Allow newer versions of ruby-zip
+Author: Unit 193 <unit193@ubuntu.com>
+
+--- ruby-roo-2.8.2.orig/roo.gemspec
++++ ruby-roo-2.8.2/roo.gemspec
+@@ -20,7 +20,7 @@ Gem::Specification.new do |spec|
+ spec.required_ruby_version = ">= 2.3.0"
+
+ spec.add_dependency 'nokogiri', '~> 1'
+- spec.add_dependency 'rubyzip', '>= 1.2.1', '< 2.0.0'
++ spec.add_dependency 'rubyzip', '>= 1.2.1'
+
+ spec.add_development_dependency 'rake', '~> 10.1'
+ spec.add_development_dependency 'minitest', '~> 5.4', '>= 5.4.3'
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..374ada5
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+allow-newer-rubyzip.patch