summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1b74e66
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+SUBDIRS := etc/xdg/xdg-xebian/Thunar/po usr/share/polkit-1/actions/po
+
+all:
+ @echo "Nothing to build, call 'make install' instead."
+
+install:
+ mkdir -pv $(DESTDIR)
+ cp -a etc usr $(DESTDIR)/.
+ # po generation
+ for i in $(SUBDIRS); do \
+ make -C $(DESTDIR)/$$i; \
+ rm -rf $(DESTDIR)/$$i; \
+ done
+ # remove some remaining files
+ find $(DESTDIR) -type f -iname "*.in" | xargs rm -f
+
+# vim:ts=4