summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/follow_https_redirects4
-rw-r--r--debian/patches/insecure_use_of_tmp2
3 files changed, 12 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 3e19231..61e524a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+listadmin (2.42-1.3) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * The "trigger-happy NMU" release ☹
+ * 2.42-1.2 included a fatal (syntax) error. Fixed it. Shame on me for
+ not correctly checking the patch!
+
+ -- Gunnar Wolf <gwolf@debian.org> Thu, 20 Sep 2018 12:26:39 -0500
+
listadmin (2.42-1.2) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/debian/patches/follow_https_redirects b/debian/patches/follow_https_redirects
index c54fbe6..82aec92 100644
--- a/debian/patches/follow_https_redirects
+++ b/debian/patches/follow_https_redirects
@@ -14,7 +14,7 @@ Index: listadmin-2.42/listadmin.pl
+ # Calling mailman_url with $pattern often requires the redirects
+ # _NOT_ to be resolved (i.e. for logging)
-+ my $nopattern = !( defined($pattern) or $pattern )
++ my $nopattern = !( defined($pattern) or $pattern );
my ($lp, $domain) = split ('@', $list);
$pattern ||= uio_adminurl ($domain);
@@ -23,7 +23,7 @@ Index: listadmin-2.42/listadmin.pl
}
$url .= "?$params" if $params;
+
-+ $url = resolve_redirects($url) unless $nopattern;
++ $url = resolve_redirects($url) if $nopattern;
return $url;
}
diff --git a/debian/patches/insecure_use_of_tmp b/debian/patches/insecure_use_of_tmp
index 4523a47..b2a35f4 100644
--- a/debian/patches/insecure_use_of_tmp
+++ b/debian/patches/insecure_use_of_tmp
@@ -16,7 +16,7 @@ Index: listadmin-2.42/listadmin.pl
my $rc = $ENV{"HOME"}."/.listadmin.ini";
-@@ -727,12 +728,12 @@ sub get_list {
+@@ -730,12 +731,12 @@ sub get_list {
if ($page !~ get_trans_re("pending_req")) {
my $msg = "unexpected contents";