summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLibravatarNoèl Köthe <noel@debian.org>2009-07-21 00:36:37 +0200
committerLibravatarUnit 193 <unit193@ubuntu.com>2019-12-05 16:35:23 -0500
commit4c4e2901326f831cf2e3c72d1a25276f705464ca (patch)
tree392b8734e393a3994fb1e690a0318e635daae34d
parent87877d1509ac0cb2bf8c7d89b51f409236627746 (diff)
downloadlistadmin-debian/2.40-3.tar.bz2
listadmin-debian/2.40-3.tar.xz
listadmin-debian/2.40-3.tar.zst
Import Debian changes 2.40-3debian/2.40-3
listadmin (2.40-3) unstable; urgency=low * updated Standards-Version (no changes needed) * debian/compat updated to 5 * added listadmin-discard.patch from Alexander Wirt <formorer@debian.org> Thanks! (closes: #530385)
-rw-r--r--debian/changelog9
-rw-r--r--debian/compat2
-rw-r--r--debian/control4
-rw-r--r--debian/patches/listadmin-discard.patch57
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules40
6 files changed, 80 insertions, 34 deletions
diff --git a/debian/changelog b/debian/changelog
index cf74935..a067c0f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+listadmin (2.40-3) unstable; urgency=low
+
+ * updated Standards-Version (no changes needed)
+ * debian/compat updated to 5
+ * added listadmin-discard.patch from Alexander Wirt
+ <formorer@debian.org> Thanks! (closes: #530385)
+
+ -- Noèl Köthe <noel@debian.org> Tue, 21 Jul 2009 00:36:37 +0200
+
listadmin (2.40-2.2) unstable; urgency=low
* Fix regression in earlier NMU (in some cases ignored pending
diff --git a/debian/compat b/debian/compat
index b8626c4..7ed6ff8 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-4
+5
diff --git a/debian/control b/debian/control
index eb02f54..ebfeb62 100644
--- a/debian/control
+++ b/debian/control
@@ -2,8 +2,8 @@ Source: listadmin
Section: net
Priority: optional
Maintainer: Noèl Köthe <noel@debian.org>
-Build-Depends: debhelper (>= 4.0.0)
-Standards-Version: 3.8.0
+Build-Depends: debhelper (>= 5.0.0), quilt
+Standards-Version: 3.8.2
Homepage: http://heim.ifi.uio.no/kjetilho/hacks/#listadmin
Package: listadmin
diff --git a/debian/patches/listadmin-discard.patch b/debian/patches/listadmin-discard.patch
new file mode 100644
index 0000000..86b8ecb
--- /dev/null
+++ b/debian/patches/listadmin-discard.patch
@@ -0,0 +1,57 @@
+diff --git a/listadmin.pl b/listadmin.pl
+index 42b365c..71c7a08 100755
+--- a/listadmin.pl
++++ b/listadmin.pl
+@@ -254,7 +254,7 @@ sub process_subscriptions {
+ }
+ my $count = keys (%subscribers);
+ my $def = $config->{"subdefault"};
+- my $prompt = 'Accept/Reject/Skip/Quit';
++ my $prompt = 'Accept/Discard/Reject/Skip/Quit';
+ $prompt .= " [" . uc($def) . "]" if $def;
+ $prompt .= " ? ";
+
+@@ -281,6 +281,9 @@ sub process_subscriptions {
+ } elsif ($ans eq "a") {
+ $change->{$id} = [ "sa" ];
+ last;
++ } elsif ($ans eq "d") {
++ $change->{$id} = [ "sd" ];
++ last;
+ } elsif ($ans eq "r") {
+ my $r = prompt ("Why do you reject? [optional] ");
+ unless (defined $r) {
+@@ -295,6 +298,7 @@ and pressing Return.
+
+ a Accept -- allow the user to join the mailing list
+ r Reject -- notify sender that the request was turned down
++ d Discard -- silently discard the request
+ s Skip -- do not decide now, leave it for later
+ q Quit -- go on to approving messages
+
+@@ -1377,6 +1381,7 @@ sub set_param_values {
+ "d" => 3,
+ "sa" => 4, # subscribe approve
+ "sr" => 2, # subscribe reject
++ "sd" => 3, # subsribe discard
+ };
+ } else {
+ $data->{"global"}{"actions"} = { "a" => 0,
+@@ -1411,7 +1416,7 @@ sub read_config {
+
+ my %act = ("approve" => "a", "discard" => "d",
+ "reject" => "r", "skip" => "s", "none" => "");
+- my %sact = ("accept" => "a",
++ my %sact = ("accept" => "a", "discard" => "d",
+ "reject" => "r", "skip" => "s", "none" => "");
+
+ return undef unless open (CONF, $file);
+@@ -1641,7 +1646,7 @@ sub commit_changes {
+ for my $id (sort { $a <=> $b } keys %{$change}) {
+ my ($what, $text) = @{$change->{$id}};
+ $params->{$id} = $action->{$what};
+- unless ($what =~ /^s[ar]$/) {
++ unless ($what =~ /^s[ard]$/) {
+ # we don't log subscription approval or rejects
+ $log .= sprintf ("%s D:[%s] F:[%s] S:[%s]\n",
+ $what,
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..c7b2de6
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+listadmin-discard.patch
+
diff --git a/debian/rules b/debian/rules
index 40beed2..596fe28 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,16 +1,9 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-
-
+include /usr/share/quilt/quilt.make
CFLAGS = -Wall -g
@@ -20,7 +13,7 @@ else
CFLAGS += -O2
endif
-configure: configure-stamp
+configure: patch configure-stamp
configure-stamp:
dh_testdir
# Add here commands to configure the package.
@@ -28,7 +21,7 @@ configure-stamp:
touch configure-stamp
-build: build-stamp
+build: configure build-stamp
build-stamp: configure-stamp
dh_testdir
@@ -39,7 +32,9 @@ build-stamp: configure-stamp
touch build-stamp
-clean:
+clean: clean-patched unpatch
+
+clean-patched:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
@@ -63,38 +58,21 @@ install: build
# Build architecture-independent files here.
binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs
dh_installdocs
-# dh_installexamples
-# dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
dh_installman
dh_link
dh_strip
dh_compress
dh_fixperms
-# dh_perl
-# dh_python
-# dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary: binary-indep
+.PHONY: build clean binary-indep binary install configure patch unpatch
+